Project

General

Profile

Actions

Sim-Development #1527

closed

[WARN] Daq: ignore digi from system TRD at time 36875 for Time slice [971850000.000, 971860000.000] ns, data: empty

Added by Anna Senger over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
High
Target version:
Start date:
02/07/2020
Due date:
% Done:

100%

Estimated time:
5.00 h
Spent time:

Description

I run run_digi(1000,"muons",1e7,1e4,kFALSE) and suddenly get hundreds of lines like:
[WARN] Daq: ignore digi from system TRD at time 36875 for Time slice [971760000.000, 971770000.000] ns, data: empty
[WARN] Daq: ignore digi from system TRD at time 36875 for Time slice [971770000.000, 971780000.000] ns, data: empty
[WARN] Daq: ignore digi from system TRD at time 36875 for Time slice [971780000.000, 971790000.000] ns, data: empty
[WARN] Daq: ignore digi from system TRD at time 36875 for Time slice [971790000.000, 971800000.000] ns, data: empty
...
I break the run with ^C. Can TRD run in time-based mode?
Anna


Files

run_digi.log (1.75 MB) run_digi.log Anna Senger, 02/07/2020 02:10 PM

Related issues

Related to Simulation - Sim-Development #1538: Adaption of digitizer classesClosedVolker Friese02/15/202002/17/2020

Actions
Actions #1

Updated by Anna Senger over 2 years ago

After line [INFO] ----- Daq: Closing Time slice
comes
[WARN] Daq: ignore digi from system TRD...

[INFO] DigitizationSource: Event 120 at t = 12187.277 ns from input 0 (entry 120)
[INFO] + StsDigitize : Event 120 at 12187.277 ns, points: 95, signals: 573 / 568, digis: 3340. Exec time 0.137961 s.
[INFO] + MuchDigitizeGem: Event 120 at 12187.277 ns, points: 98, signals: 169, digis: 1911. Exec time 0.013538 s.
[INFO] + TrdDigitize: Event 120 at 12187.277 ns, points: 114, digis: 412. Exec time 0.069086 s.
[INFO] + TofDigitize: Event 120 at 12187.277 ns, points: 881, digis: 330. Exec time 0.007154 s.
[INFO] + Daq: Event 120 at 12187.277 ns, 6887 digis transported. Exec time 0.017647 s.

[INFO] DigitizationSource: Event 121 at t = 12254.299 ns from input 0 (entry 121)
[INFO] + StsDigitize : Event 121 at 12254.299 ns, points: 168, signals: 1142 / 1127, digis: 47. Exec time 0.145456 s.
[INFO] + MuchDigitizeGem: Event 121 at 12254.299 ns, points: 151, signals: 268, digis: 7. Exec time 0.023887 s.
[INFO] + TrdDigitize: Event 121 at 12254.299 ns, points: 123, digis: 315. Exec time 0.071324 s.
[INFO] + TofDigitize: Event 121 at 12254.299 ns, points: 780, digis: 304. Exec time 0.006555 s.
[INFO] ----- Daq: Closing Time slice [0.000, 10000.000] ns, data: [1750.000, 9992.000] ns, STS 423559 MUCH 82309 TRD 25114 TOF 28792
[INFO] + Daq: Event 121 at 12254.299 ns, 10127 digis transported. Exec time 0.830665 s.

[INFO] DigitizationSource: Event 122 at t = 12377.307 ns from input 0 (entry 122)
[INFO] + StsDigitize : Event 122 at 12377.307 ns, points: 2480, signals: 11985 / 11677, digis: 80. Exec time 0.652515 s.
[INFO] + MuchDigitizeGem: Event 122 at 12377.307 ns, points: 2300, signals: 3843, digis: 446. Exec time 0.211611 s.
[INFO] + TrdDigitize: Event 122 at 12377.307 ns, points: 83, digis: 722. Exec time 0.074256 s.
[INFO] + TofDigitize: Event 122 at 12377.307 ns, points: 500, digis: 186. Exec time 0.006277 s.
[WARN] Daq: ignore digi from system TRD at time 2562.5 for Time slice [10000.000, 20000.000] ns, data: [10008.000, 10254.000] ns, STS 7336 MUCH 1285 TRD 127 TOF 732
[INFO] + Daq: Event 122 at 12377.307 ns, 2801 digis transported. Exec time 0.007618 s.

Actions #2

Updated by Anna Senger over 2 years ago

I checked: only TRD digis from first time slice are stored in muons.raw.root file

Actions #3

Updated by Volker Friese over 2 years ago

  • Tracker changed from Feature to Sim-Development
  • Project changed from CbmRoot to Simulation
  • Status changed from New to Assigned
  • Assignee changed from Florian Uhlig to Etienne Bechtel
  • Priority changed from Normal to High
  • Target version set to APR20
  • Estimated time set to 5.00 h

I confirm the finding. This appears to happen in CbmTrdDigitize::Finish(). For some reason, there are digis produced and sent to the DAQ with a time stamp very much different from the system time (time of last event).

It seems not to happen in the Exec() method, i.e. before the end of the run.

In the DAQ, the digis have to be buffered to be able to sort them into time-slices and to ensure a time-ordered output array. For this, I have to assume some latency (maximal time disordering), which is tentatively set to 2000 ns. This value can be increased, of course, but not to the level of seconds as would be necessary from your output.

Etienne, could you please have a look? Maybe you know by heart what is going on here.

Actions #4

Updated by Volker Friese over 2 years ago

Actions #5

Updated by Etienne Bechtel over 2 years ago

  • Status changed from Assigned to In Progress

I am looking into it. It should be something small and I have an idea what could be happening.

Actions #6

Updated by Etienne Bechtel over 2 years ago

  • % Done changed from 0 to 90

Hello Anna,

I changed the FlushBuffer() call in the CbmTrdDigitizer steering class for the rectangular design (revision @15713). The problem was caused by different buffer handlings. I just checked it and it seems to solve the problem for me. Please report back if you can confirm this.

Best regards
Etienne

Actions #7

Updated by Anna Senger over 2 years ago

Hello Etienne.
This problem is disappeared. Thank you!
Regards
Anna

Actions #8

Updated by Etienne Bechtel over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
Actions #9

Updated by Volker Friese over 2 years ago

  • Status changed from Resolved to Closed

The issue is fixed.

Actions

Also available in: Atom PDF