Project

General

Profile

Actions

Support #1578

closed

Vector input to CbmMcbm2018EventBuilder

Added by Vikas Singhal about 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
02/26/2020
Due date:
% Done:

100%

Estimated time:

Description

Dear Florian,

We try to use the CbmMcbm2018EventBuilder for simulated timeslice, but as it expects Branches of different subsystem digis in TClonesArray and STS, MUCH, TRD providing digi branch in vector after digitizer therefore it does event building except mentioned 3 subsystem for simulated timeslices.
Can you modify CbmMcbm2018EventBuilder accordingly.

Regards
Vikas

Actions #1

Updated by Florian Uhlig about 2 years ago

  • Status changed from New to In Progress
  • Assignee changed from Florian Uhlig to Vikas Singhal
  • % Done changed from 0 to 40

Volker modified meanwhile all digi classes and also adapted the task CbmMcbm2018EventBuilder. Could you please check if it is working now.

Actions #2

Updated by Pierre-Alain Loizeau about 2 years ago

My commit r15878 probably breaks it again due to the branch names. Will be fixed SoonTM (this evening or tomorrow) when implementing #1585 in all mCBM classes.

Actions #3

Updated by Vikas Singhal about 2 years ago

Dear Pierre,

Today I tried with cbmroot r15896, and tried to do event building of simulated data. So just for update getting 2 issue:-

1. By default, event builder is looking for CbmMuchBeamTimeDigi but for simulated timeslice CbmMuchDigi is the branch name. Therefore I disable line number 67 in CbmMcbm2018EventBuilder.

fDigiMan->UseMuchBeamTimeDigi();

2. After this got another error which you mentioned yesterday during Software meeting (getting boost any_cast error.) ===================
I run_reco_tb_event: Starting run
[INFO] FairRunAna::Run() After checking, the run will run from event 0 to 2.
[INFO] Begin of TS 0
[FATAL] Failed boost any_cast in Digimanager::Get for a digi of type CbmMuchBeamTimeDigi ==================

Update accordingly.
Vikas

Actions #4

Updated by Volker Friese almost 2 years ago

Dear Vikas,

what is the status here?

Actions #5

Updated by Pierre-Alain Loizeau almost 2 years ago

  • Assignee changed from Vikas Singhal to Pierre-Alain Loizeau

It should be checked if the issue is solved in the development branch. If it is the case we should backport the fix to trunk and release.

=> After rereading this issue and the #1585, I think I understand again where the problem lies: the event builder is using CbmMuchBeamTimeDigi, which is only avavilable for real data.
=> We would need a switch/flag to select between CbmMuchDigi and CbmMuchBeamTimeDigi, I will try to implement this this evening
=> This hack will anyway pop up again when we cleanup the situation with the 2 Digi classes, so no need for a separate issue to remember that this should be cleaned up.

=> r.16468 should provide the needed functionality. Please let me know if this is enough or if we need further tuning.

Actions #6

Updated by Pierre-Alain Loizeau almost 2 years ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Pierre-Alain Loizeau to Vikas Singhal
  • % Done changed from 40 to 90
Actions #7

Updated by Volker Friese almost 2 years ago

  • Target version changed from APR20 to APR21

Since this affects the development branch mCBM2020, which will be merged to the main directory in git, this issue need not block APR20. I thus change the target version.

Actions #8

Updated by Florian Uhlig 11 months ago

What about the issue? Is it solved meanwhile?

Actions #9

Updated by Vikas Singhal 11 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 90 to 100

Dear Florian,
I have not checked now but it had resolved, so issue may be closed.

Vikas

Actions

Also available in: Atom PDF