Project

General

Profile

Actions

Bug #1985

closed

Error during useing CbmEventBuilderIdeal class

Added by Vikas Singhal over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
01/25/2021
Due date:
% Done:

100%

Estimated time:

Description

Dear Volker,

As we discussed during MUCH Weekly Meeting that we will try to use CbmEventBuilderIdeal class for simulated time sliced data, Both Shreya and Sayak tried to use it but it looks corresponding library not created correctly therefore showing below error :-

Processing run_reco_tb_event_ideal.C...
cling::DynamicLibraryManager::loadLibrary(): /lustre/cbm/users/sroy/git_cbmroot_Nov2020/cbmroot/build/lib/libCbmEventBuilder.so.0.0.0: undefined symbol: _ZN16CbmBuildEventsQA8StreamerER7TBuffer
Error in <TInterpreter::TCling::AutoLoad>: failure loading library CbmEventBuilder.so for CbmBuildEventsIdeal

  • Break *** segmentation violation

Let us know how to resolve this issue.

Thanks and regards,
Vikas

Actions #1

Updated by Florian Uhlig over 1 year ago

  • Assignee changed from Volker Friese to Vikas Singhal

Dear Vikas,

could you please add the macro such that we can reproduce the error.

Ciao

Florian

Actions #2

Updated by Vikas Singhal over 1 year ago

Dear Florian,

Macro containing CbmEventBuilderIdeal is working with the trunk version. Earlier we tried with Apr20 version and due to that get error message. Probably we may close this issue.

We are working further with output where events inside one time slice. Hit reconstruction is working but tracks are not created. We will create a new issue if could not succeed for track reconstruction after event building on time sliced data.

Regards
Vikas

Actions #3

Updated by Florian Uhlig over 1 year ago

Is the problem solved? If so please close the issue.

Actions #4

Updated by Vikas Singhal over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Issue may be closed.
Vikas

Actions #5

Updated by Volker Friese over 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF