Project

General

Profile

Actions

Bug #2039

closed

Error during running Monitoring Macros

Added by Vikas Singhal about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
High
Target version:
Start date:
03/16/2021
Due date:
% Done:

100%

Estimated time:
Spent time:

Description

Dear Pierre,

With the latest git version we could not run the Monitoring macro. It shows below fatal error:-

[INFO] FairRunOnline::InitContainers: event header at 0x558daeada430
[FATAL] The sink does not exist to store persistent branches.
For later analysis we write a core dump to core_dump_71986

Recently have you changed anything related to the Source class or anything changed in FariRunOnline?

I do not know which MR created this issue, but we could run monitoring with below revision.

vikas@vsinghal-debian:~/daqsoft/git/cbmroot/fles/mcbm2018$ git rev-parse --short HEAD
83eaebdc

The error is same for all the Monitoring Macros like for STS, TO etc.

Kindly update accordingly.
Vikas

Actions #1

Updated by Pierre-Alain Loizeau about 1 year ago

Dear Vikas,

Could you please tell me which version of FairSoft and FairRoot you are using?

I am running the nightly tests for the monitors only on one versions set (Debian10-linux-x86_64-gcc8-fairsoft_jun19p2-fairroot_v18.2.1 see for example last night testing ), so it could be that one of the latest commits broke compatibility with other versions.

So my short term plan would be that I test it and try to patch, later I will try to see with Florian if we could use containers to expand the coverage.

Cheers
P-A

Actions #2

Updated by Vikas Singhal about 1 year ago

Dear Pierre,

Versions used are :

Fairsoft jun 19 p2
Fairroot_v18.4.0

but on the nightly test, FairRoot version is different.
Ok, we will try with FairRoot_v18.2.1.

Vikas

Actions #3

Updated by Vikas Singhal about 1 year ago

Dear Pierre,

Monitoring Macros are running with FairRoot_v18.2.1, but not with FairRoot_v18.4.0. Can you elaborate what changes done with new FairRoot with respect to containers?

Later I will close this issue.

Thanks,
Vikas

Actions #4

Updated by Florian Uhlig about 1 year ago

Dear Vikas,

could you tell me what I have to do to create the error such that I can test myself.

Actions #5

Updated by Florian Uhlig about 1 year ago

Dear Vikas,

could you try to add the following line after the creation of the FairRunOnline instance

run->SetOutputFile("bla.root");

Actions #6

Updated by Pierre-Alain Loizeau about 1 year ago

  • % Done changed from 0 to 50

I can confirm both the error (with jun19p1 and v18.4.0) and the temporary fix proposed by Florian.

I remember removing the explicit addition of the event header from all monitoring macros to be able to run without generating un-needed output files.
It seems that the addition of an EventHeader somehow became automatic in v18.3.x or v18.4.x even when running with FairRunOnline instead of FairRunSim or FairRunAna.

=> I will try to track it in FairRoot and make an issue there so that it is corrected and we jump do a version without it for our next FairSoft + FairRoot pair.

Actions #7

Updated by Pierre-Alain Loizeau about 1 year ago

huum, it seems that it may well have been there since ever:
  • The error message was introduced in FairRootManager by FairRoot commit bca6a1aa which was actually a fix for a bug I reported myself in FairRoot issue 935
  • The usage of the event header in FairRunOnline was always there since the 5-7 years ago

The actual problem is with line 185 in FairRunOnline, which attempt to force the writing of the EventHeader without checking is a sink exists first (kTRUE flag):

fRootManager->Register("EventHeader.", "Event", fEvtHeader, kTRUE);

@Florian: I think I could propose an MR to FairRoot changing it to

fRootManager->Register("EventHeader.", "Event", fEvtHeader, (nullptr != fRootManager->GetSink()));

Would it make sense to try to get it as quick patch in v18.6.0 which is 9 days old and in sync with the master HEAD? or should it be also a patch for the last v18.4.x release?

Actions #8

Updated by Pierre-Alain Loizeau about 1 year ago

  • Status changed from In Progress to Feedback

Should be solved with FairRoot patch version 18.4.5 and 18.6.3.

Should I close this issue or should we wait until we update our default FairRoot versions so we keep it in mind?

Actions #9

Updated by Vikas Singhal about 1 year ago

  • % Done changed from 50 to 100

Dear Pierre,
Yes we may close this issue.

Vikas

Actions #10

Updated by Pierre-Alain Loizeau about 1 year ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF