Project

General

Profile

Actions

Bug #2297

closed

Overlap in mTRD or mTRD-2D latest geometry

Added by Pierre-Alain Loizeau 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
10/20/2021
Due date:
% Done:

0%

Estimated time:

Description

The are a few internal overlaps in the latest mTRD geometry, probably due to the introduction of the 2D modules from what I see in the graph shown yesterday by Eoin in the mCBM meeting.

See https://cdash.gsi.de/testDetails.php?test=9618221&build=296672.

Are these overlap expected, in which case David could add some exception with log printouts?
Or should they be resolved?

Actions #1

Updated by Pascal Raisig 7 months ago

  • Assignee changed from Pascal Raisig to Alexandru Bercuci

Since, Alex knows more details on the 2D geometry I forwarded the assignment.

Actions #2

Updated by Alexandru Bercuci 7 months ago

Yes, the overlap happens in the TRD-2D modules, namely in the FEE part. It is very nice to have this tool to spot such problems. I will fix it asap
Alex

Actions #3

Updated by Pierre-Alain Loizeau 7 months ago

  • Status changed from New to In Progress

Since this is a fix of a new geometry, I think it would make sense to overwrite the file in the geometry repository instead of popping a new tag, right?

Actions #4

Updated by Alexandru Bercuci 7 months ago

  • Assignee deleted (Alexandru Bercuci)

Sure. Fully agree

Actions #5

Updated by David Emschermann 7 months ago

Yes, overwrite it. Also please check the previous TRD-2D geometry version if it has the same overlap.

Actions #6

Updated by Pierre-Alain Loizeau 6 months ago

  • Status changed from In Progress to Feedback
  • Assignee set to Pierre-Alain Loizeau

Should be fixed with MRs 565 and 566

Actions #7

Updated by Pierre-Alain Loizeau 6 months ago

  • Status changed from Feedback to Closed

Confirmed to be fixed.

Actions

Also available in: Atom PDF