Project

General

Profile

Actions

Bug #2443

closed

Wrong Z position of the MUCH hits in shifted geometry

Added by Anna Senger 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
02/17/2022
Due date:
% Done:

100%

Estimated time:

Description

Hello.
I tested muon setups sis100_muon_lmvm*. I found strange analysis results. Some I put here (MUCHchi2.png: red and blue lines for shifted setup, TOF_APR21.png and TOF_DEC21.png). I tried to understand results, and I found, that MUCH MC points have right Z positions in shifted geometry, but hits are unshifted. I don't know, who is responsible for MUCH detector software, but this issue has to corrected.


Files

MUCHpoints.PNG (31.9 KB) MUCHpoints.PNG Anna Senger, 02/17/2022 03:43 PM
MUCHhits.PNG (40.5 KB) MUCHhits.PNG Anna Senger, 02/17/2022 03:43 PM
TOF_DEC21.PNG (41.9 KB) TOF_DEC21.PNG Anna Senger, 02/17/2022 03:43 PM
TOF_APR21.PNG (63.2 KB) TOF_APR21.PNG Anna Senger, 02/17/2022 03:43 PM
MUCHchi2.PNG (32.2 KB) MUCHchi2.PNG Anna Senger, 02/17/2022 03:43 PM
Actions #1

Updated by Florian Uhlig 8 months ago

  • Assignee changed from Florian Uhlig to Vikas Singhal

Hi Vikas,

I think you are the proper person to check the issue.

Could it be that the detector positions are hardcoded in the parameter files?

Actions #2

Updated by Florian Uhlig 7 months ago

Vikas Singhal,

did you find the time to check the issue?

Actions #3

Updated by Vikas Singhal 7 months ago

Dear Anna and Florian,

Apology for not to update on the ticket. Yes, we looked into the shifted z position of reconstructed MuCh hits in detail. We implemented correction of z position via below 2 solutions:-

1: Translating the z position in the CbmMuchFindHitsGem class by the amount which is shifted due to the new Coordinate System (as per new Vertex/target position).

2: The Z position has been read from the *.par file during the segmentation process and the *.par file has been generated with the root geometry file during the root geometry creation process.

Both solutions have pros and cons. Now tomorrow (14:30IST) we have a dedicated meeting with Anna to discuss proper implementation and also to discuss the possible implications of the shifted vertex position on the physics performance.

http://meet.google.com/vty-vzas-tnc

Regards
Vikas

Actions #4

Updated by Florian Uhlig 7 months ago

Dear Vikas,

thanks for your answer. In my opinion both options shouldn't be used.

1: Translating the z position in the CbmMuchFindHitsGem class by the amount which is shifted due to the new Coordinate System (as per new Vertex/target position).

This option is a no go. We currently have several setups which differ by the origin and such thing shouldn't be hard coded. If you implement something like that we will face the problem whenever some setup or geometry is changed.

2: The Z position has been read from the *.par file during the segmentation process and the *.par file has been generated with the root geometry file during the root geometry creation process.

This is also no good solution but will serve as a quick fix for the problem. How do you for example intend to apply (mis)alignment of the MUCH detector. The current scheme already used in mCBM is to modify the geometry. With your hardcoded positions this can't work for the MUCH.

The proper solution is to take the geometry properties like position, size .. from the TGeoManager. The TGeoManger stores the whole information about the geometry and can be used at any stage of the simulation, digitisation, reconstruction and analysis chain.

Actions #5

Updated by Anna Senger 7 months ago

  • Status changed from New to Closed
  • Assignee changed from Vikas Singhal to Anonymous

I checked new parameter file, and MUCH MC points and hits are at the same Z position. Thank you Om

Actions #6

Updated by Florian Uhlig 7 months ago

  • Status changed from Closed to Feedback
  • Assignee changed from Anonymous to Anna Senger

Which new parameter file? Is it in the repository? I haven't seen any merge request.

Actions #7

Updated by Anna Senger 7 months ago

  • Assignee changed from Anna Senger to Anonymous

Om has to make merge request. I have private version from Om only

Actions #8

Updated by Anonymous 7 months ago

I have created a merge request for a parameter file of v20c default geometry.

Apology for the delay.

Best Regards,
Om

Actions #9

Updated by Florian Uhlig 7 months ago

  • Assignee changed from Anonymous to Anna Senger

Anna Senger,

the merge request was merged.
could you please check that the committed file is the same one you have got privately.

Actions #10

Updated by Anna Senger 7 months ago

  • Assignee changed from Anna Senger to Anonymous

Om, can you explaine me, please, which geometry I need to check. The 21c or 20c?
Deafault version in DEC21 setup is 21c
TString muchGeoTag = "v21c_sis100_1m_lmvm";

Actions #11

Updated by Anna Senger 7 months ago

v20c: geometry is shifted, parameter - not.
The Z position of the hits is shifted in +40 cm dowstream.
The problem is not solved

Actions #12

Updated by Eoin Clerkin 7 months ago

Hi Anna Senger
v21c should be v21a but with coordinate change (shift by 40cm)
v20c should be v20a with coordinate change (shift by 40cm)

We want to get to the DEC21 geometries, so v21c is the more important.

I would imagine the parameter needs shifting for both v20c and v21c as they were generated same way.

Hits should be -40cm, upstream not downstream.

Actions #13

Updated by Anna Senger 7 months ago

  • Assignee changed from Anonymous to Florian Uhlig

Do I need to make:
git clone https://git.cbm.gsi.de/f.uhlig/cbmroot florian
cd florian
git checkout dec21_patches
?
If yes, then hits are still in wrong position

Actions #14

Updated by Anonymous 7 months ago

Dear Anna, I have committed v20c parameter file. If v21a is required I will commit it too. Then I think we can copy it for v21c.

Actions #15

Updated by Anonymous 7 months ago

Dear Florian,
I have created a merge request for a parameter file of v21c default geometry for the DEC21 setup.

Actions #16

Updated by Florian Uhlig 7 months ago

  • Assignee changed from Florian Uhlig to Anna Senger

Anna Senger,

I have merged the last change of Om in the parameter repository and created a test branch for the dec21_patches in my repository. Please test it and report if the placement of the much hits are now correct.

git clone https://git.cbm.gsi.de/f.uhlig/cbmroot florian
cd florian
git checkout dec21_patches
Actions #17

Updated by Anna Senger 7 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Anna Senger to Florian Uhlig

Florian Uhlig

The MUCH hits are at the same position as MC points for v20c and v21c MUCH geometry.

Actions #18

Updated by Florian Uhlig 7 months ago

  • Assignee changed from Florian Uhlig to Anna Senger

Fixed in the master branch as well as in the dec21_patches branch.

Actions #19

Updated by Anna Senger 7 months ago

  • Status changed from Resolved to Closed

Thank you very much

Actions #20

Updated by Florian Uhlig 7 months ago

  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF