Project

General

Profile

Actions

Development #329

closed

Revise StsTrack class

Added by Florian Uhlig almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
09/10/2015
Due date:
% Done:

100%

Estimated time:
5.00 h
Spent time:

Description

The function GetNofHits of the StsTrack class returns only the number of hits in the STS detector. At some time in the past the function returned the number of hits in MVD+STS.
The function should be changed to the old behavior. There should be also new functions

GetNofStsHits and GetNofMvdHits which will return only the number of hits for the respective subsystem.

Correct all other code which use the functions.

The issue was discussed in the CBM Reconstruction Metting at 08.07.15 (https://indico.gsi.de/conferenceDisplay.py?confId=3931)


Related issues

Related to CbmRoot - Development #320: CbmTrackMatchNew problem with Mvd only tracks.ClosedVolker Friese07/06/2015

Actions
Follows CbmRoot - Infrastructure #357: Exclude analysis/timing from Doxygen buildClosedFlorian Uhlig09/07/201509/09/2015

Actions
Actions #1

Updated by Volker Friese almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Volker Friese
  • Estimated time changed from 4.00 h to 5.00 h

CbmStsTrack::GetNofHits() always returned the number of STS hits, which is the behaviour of the mother class CbmTrack. I agree to the proposal of introducing separate accessors for MVD and STS hits. Will have to make CbmTrack::GetNofHits() virtual, such that it can be overloaded in CbmStsTrack (to give to the total number of hits).

Actions #2

Updated by Volker Friese almost 7 years ago

  • Status changed from Assigned to In Progress
  • % Done changed from 0 to 40

I have implemented the accessors GetNofStsHits() and GetNofMvdHits() in CbmStsTrack. CbmTrack::GetNofHits() is now virtual. For the time being, CbmStsTrack::GetNofHits() just refers to that, i.e. gives the number of STS hits as before. Before I change the behaviour of this function, I want to see all references to it by other classes; they will be numerous, I guess. This is currently not possible with Doxygen (see #357).

Actions #3

Updated by Volker Friese almost 7 years ago

  • Start date changed from 09/08/2015 to 09/10/2015

due to changes in a related task

Actions #4

Updated by Volker Friese almost 7 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100

The required functionality was implemented. CbmStsTrack::GetNofHits() now returns the sum of the numbers of STS and MVD hits.

I changed all occurences in other code that I found with the help of Doxygen. This concerns the directories KF, analysis/hyperon, base, hadorn and rich. Please have a look at r8365 and check whether this still is the desired behaviour.

Actions #5

Updated by Florian Uhlig almost 7 years ago

  • Assignee changed from Volker Friese to Philipp Sitzmann

For me the code looks okay. If Philipp Sitzmann, the original reporter of the issue, confirm that the problem is solved for him, you can close the ticket.

Actions #6

Updated by Philipp Sitzmann almost 7 years ago

With new functions the behaviour is more clear.
Issue is in my case solved.

Actions #7

Updated by Florian Uhlig almost 7 years ago

  • Status changed from Resolved to Closed
Actions #8

Updated by Julian Book almost 7 years ago

Hi,
unfortunately I cannot reopen this issue (on purpose?). First of all not all occurrences in the code have been changed (see e.g. analysis/papa/PairAnalysis.cxx), so people should be informed somehow or everybody with commit rights in the projects needs to be added to the issue as watcher.

The second things, that is not clear to me is: what is now returned by CbmStsTrack::GetHitIndex(Int_t) which comes from CbmTrack, are these the indices of the STS hits or STS+MVD hits? Do we need here a separate function aka CbmStsTrack::GetMvdHitIndex() for STS hits only?

Please let me know.
Cheers, Julian

Actions #9

Updated by Volker Friese almost 7 years ago

  • Status changed from Closed to Feedback
  • Assignee changed from Philipp Sitzmann to Julian Book

CbmStsTrack::GetHitIndex() returns the STS hit index as before (inherited from CbmTrack).
There is also a method CbmStsTrack::GetStsHitIndex(), which should be used instead.

A "combined" index of STS+MVD hit does not make sense, since STS and MVD hits are in two different arrays.

Sorry to have overlooked the occurence in papa.

There is no purpose in your not being able to re-open the issue. This case is probably not reflected in our workflow.

Actions #10

Updated by Volker Friese almost 7 years ago

It seems the reason why I have not seen the occurence of CbmStsTrack::GetNofHits() in PairAnalysis.cxx is that the Doxygen documentation is out of date. I considered all occurences listed there under "referenced by", where PairAnalysis did not appear. Sorry for that. I have created an infrastructure issue requesting that the Doxygen be built nigthly again. Morover, I have published the API change in the news section.

If you agree, I would like to close the issue then again.

Actions #11

Updated by Julian Book over 6 years ago

  • Status changed from Feedback to Resolved

Hi Volker, many thanks for your explanation and work. I think the ticket can be closed again.

Actions #12

Updated by Volker Friese over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF