Project

General

Profile

Actions

Feature #353

closed

Allow to switch data persistency in tasks from the macro

Added by Florian Uhlig almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
09/03/2015
Due date:
% Done:

100%

Estimated time:
10.00 h

Description

The FairRoot framework allows to define if the data should be written to file (persistence) for each data branch when the data branch is registered.

Unfortunately all or at least most of the tasks in CbmRoot doesn't use this feature, but have in the call of the Register function a predefined value instead of a variable as shown in the example below.

FairRootManager* ioman = FairRootManager::Instance();
ioman->Register("TrdDigi", "TRD Digis", fTrdDigis, kTRUE);

Add a data member and the corresponding Setter/Getter to the tasks which allow to switch on/off persistency from the macro. Since such a data member is not foreseen in FairTask check the possibility to create a CbmTask which adds the needed functionality. The second alternative would be to implement the data memeber, and Getter/Setter for each task separately.


Related issues

Is duplicate of CbmRoot - Development #327: Make data persistency controllable from macrosClosedPierre-Alain Loizeau01/01/201605/27/2016

Actions
Actions #1

Updated by Florian Uhlig almost 7 years ago

  • Status changed from New to Closed
  • Assignee set to Florian Uhlig
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF