Project

General

Profile

Actions

Support #356

closed

CBMROOT installation

Added by Christian Pauly over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
09/07/2015
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:

Description

We were trying to install CBM ROOT analysis chain following the instructions
on https://redmine.cbm.gsi.de/projects/cbmroot/wiki/Install_CbmRoot

installation up to and including CBMROOT seems to work (no errros during compilation), however, running "make test"
yields a:
Start 17: checkFields
17/41 Test #17: checkFields ......................***Failed 2.52 sec
All other tests succeed without problem.

We have downloaded and linked the fieldmap as described in the instructions,
and put appropriate links in cbmroot/input directory, the link is valid.

Also, test 18 ("checkFieldMap") and test 19 ("checkFieldSym") pass without error, so it seems the files are accessible.

Did anyone encounter a similar problem ? Is maybe the test procedure outdated ? Should we worry ???

Thanks for any help

Actions #1

Updated by Florian Uhlig over 6 years ago

  • % Done changed from 0 to 10
  • Estimated time set to 2.00 h
Actions #2

Updated by Florian Uhlig over 6 years ago

Could you please do a Experimental build which will upload the results of the build and test procedure on your machine to our CDash server. There I can have a look what is going wrong.

To do a experimental build execute the following command in your build directory

make Experimental

Then CTest will take over to configure, build, and test CbmRoot. Finally it will upload the gathered information automatically to the server.

Actions #3

Updated by Christian Pauly over 6 years ago

We tried to do this.
Everythig works, something seems to be uploaded, "Submission successfull",but then we get a lot of error messages,
see log below:

kres@cbm01:/common/cbma/users/kres/software/cbm/CBMBIN$ make Experimental
Scanning dependencies of target Experimental
Site: astro4
Build name: Linux-c++
Create new tag: 20150909-0821 - Experimental
Configure project
Each . represents 1024 bytes of output
. Size of output: 0K
Error(s) when configuring the project
Build project
Each symbol represents 1024 bytes of output.
'!' represents an error and '*' a warning.
.!. Size of output: 3K
Error(s) when building project
1 Compiler errors
0 Compiler warnings
Test project /common/cbma/users/kres/software/cbm/CBMBIN
Start 1: sis100_hadron_run_sim
1/41 Test #1: sis100_hadron_run_sim ............ Passed 16.23 sec
Start 2: sis100_hadron_run_reco
2/41 Test #2: sis100_hadron_run_reco ........... Passed 15.23 sec
Start 3: sis100_hadron_run_digi
3/41 Test #3: sis100_hadron_run_digi ........... Passed 2.50 sec
Start 4: sis100_hadron_run_qa
4/41 Test #4: sis100_hadron_run_qa ............. Passed 2.22 sec
Start 5: sis100_hadron_overlap
5/41 Test #5: sis100_hadron_overlap ............ Passed 29.33 sec
Start 6: sis100_electron_run_sim
6/41 Test #6: sis100_electron_run_sim .......... Passed 18.16 sec
Start 7: sis100_electron_run_reco
7/41 Test #7: sis100_electron_run_reco ......... Passed 14.95 sec
Start 8: sis100_electron_run_digi
8/41 Test #8: sis100_electron_run_digi ......... Passed 2.53 sec
Start 9: sis100_electron_run_qa
9/41 Test #9: sis100_electron_run_qa ........... Passed 2.27 sec
Start 10: sis100_electron_overlap
10/41 Test #10: sis100_electron_overlap .......... Passed 31.75 sec
Start 11: sis300_electron_run_sim
11/41 Test #11: sis300_electron_run_sim .......... Passed 40.01 sec
Start 12: sis300_electron_run_reco
12/41 Test #12: sis300_electron_run_reco ......... Passed 55.16 sec
Start 13: sis300_electron_run_digi
13/41 Test #13: sis300_electron_run_digi ......... Passed 3.07 sec
Start 14: sis300_electron_run_qa
14/41 Test #14: sis300_electron_run_qa ........... Passed 3.95 sec
Start 15: sis300_electron_overlap
15/41 Test #15: sis300_electron_overlap .......... Passed 82.49 sec
Start 16: run
16/41 Test #16: run .............................. Passed 2.92 sec
Start 17: checkFields
17/41 Test #17: checkFields ......................***Failed 1.83 sec
Start 18: checkFieldMap
18/41 Test #18: checkFieldMap .................... Passed 1.01 sec
Start 19: checkFieldSym
19/41 Test #19: checkFieldSym .................... Passed 1.07 sec
Start 20: runProducer
20/41 Test #20: runProducer ...................... Passed 8.43 sec
Start 21: much_sim
21/41 Test #21: much_sim ......................... Passed 29.51 sec
Start 22: much_seg
22/41 Test #22: much_seg ......................... Passed 1.83 sec
Start 23: much_reco
23/41 Test #23: much_reco ........................ Passed 21.16 sec
Start 24: tof_disim
24/41 Test #24: tof_disim ........................ Passed 18.23 sec
Start 25: tof_digi1
25/41 Test #25: tof_digi1 ........................ Passed 3.69 sec
Start 26: trd_geo
26/41 Test #26: trd_geo .......................... Passed 0.71 sec
Start 27: trd_digi_gen
27/41 Test #27: trd_digi_gen ..................... Passed 1.62 sec
Start 28: trd_sim
28/41 Test #28: trd_sim .......................... Passed 18.91 sec
Start 29: trd_digi1
29/41 Test #29: trd_digi1 ........................ Passed 4.86 sec
Start 30: trd_digi2
30/41 Test #30: trd_digi2 ........................ Passed 11.60 sec
Start 31: mvd_qa1_transUrqmd
31/41 Test #31: mvd_qa1_transUrqmd ............... Passed 17.23 sec
Start 32: mvd_qa2_transDelta
32/41 Test #32: mvd_qa2_transDelta ............... Passed 61.71 sec
Start 33: mvd_qa3_digitize
33/41 Test #33: mvd_qa3_digitize ................. Passed 3.98 sec
Start 34: global_sim_electron
34/41 Test #34: global_sim_electron .............. Passed 69.40 sec
Start 35: global_reco_electron
35/41 Test #35: global_reco_electron ............. Passed 93.85 sec
Start 36: global_sim_muon
36/41 Test #36: global_sim_muon .................. Passed 75.44 sec
Start 37: global_reco_muon
37/41 Test #37: global_reco_muon ................. Passed 80.43 sec
Start 38: mvd_sim_delta
38/41 Test #38: mvd_sim_delta .................... Passed 71.62 sec
Start 39: mvd_reco_delta
39/41 Test #39: mvd_reco_delta ................... Passed 2.64 sec
Start 40: mvd_sim_no_delta
40/41 Test #40: mvd_sim_no_delta ................. Passed 25.03 sec
Start 41: mvd_reco_no_delta
41/41 Test #41: mvd_reco_no_delta ................ Passed 2.64 sec

98% tests passed, 1 tests failed out of 41

Total Test time (real) = 951.29 sec

The following tests FAILED:
17 - checkFields (Failed)
Performing coverage
Cannot find any coverage files. Ignoring Coverage request.
Submit files (using https)
Using HTTP submit method
Drop site:https://cdash.gsi.de/submit.php?project=CbmRoot
Uploaded: /common/cbma/users/kres/software/cbm/CBMBIN/Testing/20150909-0821/Build.xml
Uploaded: /common/cbma/users/kres/software/cbm/CBMBIN/Testing/20150909-0821/Configure.xml
Uploaded: /common/cbma/users/kres/software/cbm/CBMBIN/Testing/20150909-0821/Test.xml
Submission successful
Errors while running CTest
CMakeFiles/Experimental.dir/build.make:49: recipe for target 'CMakeFiles/Experimental' failed
make3: * [CMakeFiles/Experimental] Error 10
CMakeFiles/Makefile2:339: recipe for target 'CMakeFiles/Experimental.dir/all' failed
make2:
[CMakeFiles/Experimental.dir/all] Error 2
CMakeFiles/Makefile2:347: recipe for target 'CMakeFiles/Experimental.dir/rule' failed
make1:
[CMakeFiles/Experimental.dir/rule] Error 2
Makefile:278: recipe for target 'Experimental' failed
make: *
[Experimental] Error 2

Actions #4

Updated by Florian Uhlig over 6 years ago

  • % Done changed from 10 to 100

So the upload worked, even if you didn't set your environment properly. :)

You can find the results at

https://cdash.gsi.de/index.php?project=CbmRoot

Checking the failed test I can see that there is a problem with a magnetic field map.

/common/cbma/users/kres/software/cbm/CBMSRC/input/field_v12a.root does not exist

Actions #5

Updated by Florian Uhlig over 6 years ago

  • Status changed from New to Resolved
  • Assignee changed from Florian Uhlig to Christian Pauly

Please close the ticket if the problem is solved.

Actions #6

Updated by Christian Pauly over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF