Project

General

Profile

Actions

Development #366

closed

Revise CbmMCEventHeader

Added by Volker Friese almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
11/15/2015
Due date:
11/16/2015
% Done:

100%

Estimated time:
10.00 h
Spent time:

Description

The class CbmMCEventHeader was introduced some years ago to store the event plane angle, which its mother FairMCEventHeader did not contain.

Meanwhile, the event plane angle is also available from FairMCEventHeader::GetRotZ(). Similarly, FairPrimaryGenerator allows to rotate the input event by an event plane angle.

It should thus be accessed whether our CBM MC event header is still required, or whether we should use FairMCEventHeaeder instead. Similarly, we should use the event plane generation and rotation from FairPrimaryGenerator and not from CbmUrqmdGenerator. We can then possible also use FairUrqmdGenerator instead of CbmUrqmdGenerator.

The only use case that I see, which would not be covered when using the event plane on the FairPrimaryGenerator level is to have two different UrQMD events in the input, which have different event plane angles, i.e. are rotated w.r.t. each other. This seems to be a very exotic situation.


Related issues

Follows CbmRoot - Development #12: generation of the reaction plane angleClosedVolker Friese09/10/201511/14/2015

Actions
Actions #1

Updated by Volker Friese almost 7 years ago

  • Due date set to 09/30/2015
  • Status changed from Feedback to In Progress
  • Assignee changed from Florian Uhlig to Volker Friese
  • Estimated time set to 10.00 h

Discussed in the Software Meeting of 24 September 2015. CbmUrqmdGenerator and CbmMCEventHeader shall be decomissioned. The run macros must be adapted accordingly.

Actions #2

Updated by Volker Friese over 6 years ago

Confirmed by I. Selyuzhenkov: the functionality to have several inputs rotated w.r.t each other is not required. Thus, we can go with global event rotation in FairPrimaryGenerator.

Actions #3

Updated by Volker Friese over 6 years ago

The classes CbmMCEventHeader and CbmUrqmdGenerator were removed (r8754). Change in API: CbmMCEventHeader::GetPhi() -> FairMCEventHeader::GetRotZ(). Instead of CbmUrqmdGenerator, FairUrqmdGenerator should be used.

Actions #4

Updated by Volker Friese over 6 years ago

  • Status changed from In Progress to Closed
Actions #5

Updated by Volker Friese over 6 years ago

  • Due date changed from 09/30/2015 to 11/25/2015
  • Start date changed from 09/21/2015 to 11/16/2015

due to changes in a related task

Actions #6

Updated by Volker Friese over 6 years ago

  • Due date changed from 11/25/2015 to 11/16/2015
  • Start date changed from 11/16/2015 to 11/15/2015
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF