Project

General

Profile

Actions

Development #391

closed

Development #318: Reco NOV15

Test #308: globalTrack->GetLength()

Check the accuracy of global track length

Added by Volker Friese over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
10/15/2015
Due date:
11/27/2015
% Done:

100%

Estimated time:
4.00 h
Spent time:

Description

It was reported that the method CbmGlobalTrack::GetLength() delivers incorrect results, which are not usable for TOF PID. The status of this shall be checked.

Actions #1

Updated by Pierre-Alain Loizeau over 6 years ago

  • Status changed from Assigned to In Progress
  • % Done changed from 0 to 30

A plot was added to the CbmHadronAnalysis class to check the difference between the GlobalTrack Length and the Length reported by the MC TofPoints attached to the track through the TofHit. Together with an existing histogram comparing the Length reported by the GlobalTrack and the straight distance to target of the Hit, it should provide enough input for the check.

This will be tested when the batch farm is back online next week.

Actions #2

Updated by Pierre-Alain Loizeau over 6 years ago

  • Status changed from In Progress to Feedback
  • % Done changed from 30 to 100
  • Estimated time set to 4.00 h

From the plots, it seems that the Global Track length is better than the straight line distance (Offset of 7mm against less than 1 for 2 GeV protons, similar width). Deviations are seen for secondaries but are probably due to the fact that these tracks do NOT start in the target.

Additional test will be done to make sure what are the effects of TofHits from multiple tracks or such, but no effect should be observed on PID.

Actions #3

Updated by Florian Uhlig over 6 years ago

  • Parent task deleted (#308)
Actions #4

Updated by Florian Uhlig over 6 years ago

  • Parent task set to #308
Actions #5

Updated by Pierre-Alain Loizeau over 6 years ago

  • Due date set to 11/12/2015
Actions #6

Updated by Volker Friese over 6 years ago

Please report. We would like to freeze NOV15 today.

Actions #7

Updated by Pierre-Alain Loizeau over 6 years ago

I could not reproduce any worse accuracy with global track relative to straight line track. I will ask Norbert when he is back in the control room, but on my side the question seems resolved.

Actions #8

Updated by Pierre-Alain Loizeau over 6 years ago

  • Status changed from Feedback to Resolved

I asked Norbert and he had no time to do more on simulation recently. I put the issue as resolved as I could not find a problem and we can create a new one with more precise info on the problem if it ever appear again in next releases.

Actions #9

Updated by Volker Friese over 6 years ago

  • Due date changed from 11/12/2015 to 11/27/2015
  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF