Project

General

Profile

Actions

Feature #529

closed

CbmTofHitProducerNew makes too much comments !!!!!!!!!!!!!!!!

Added by Anna Senger over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
12/15/2015
Due date:
% Done:

0%

Estimated time:

Description

Hi. I run reco.C from macro/run with:

Int_t iVerbose = 0;
.....
CbmTofHitProducerNew* tofHitProd = new CbmTofHitProducerNew("TOF HitProducerNew",iVerbose);
tofHitProd->SetInitFromAscii(kFALSE);
run->AddTask(tofHitProd);

but I get millions of lines like

[INFO ] E TofHitProducerNew: detId: 1215692934 SMType: 4 SModule: 0 of 1 Module: 3 of 1 Gap: 7 Cell: 72 of 1
[INFO ] E TofHitProducerNew: detId: 85086246 SMType: 1 SModule: 40 of 1 Module: 1 of 1 Gap: 1 Cell: 5 of 1
[INFO ] E TofHitProducerNew: detId: 84037670 SMType: 1 SModule: 40 of 1 Module: 1 of 1 Gap: 0 Cell: 5 of 1
[INFO ] E TofHitProducerNew: detId: 1041499270 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 1 Cell: 62 of 1
[INFO ] E TofHitProducerNew: detId: 1042547846 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 2 Cell: 62 of 1
[INFO ] E TofHitProducerNew: detId: 1043596422 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 3 Cell: 62 of 1
[INFO ] E TofHitProducerNew: detId: 1045693574 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 5 Cell: 62 of 1
[INFO ] E TofHitProducerNew: detId: 1046742150 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 6 Cell: 62 of 1
[INFO ] E TofHitProducerNew: detId: 1047790726 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 7 Cell: 62 of 1
[INFO ] E TofHitProducerNew: detId: 1258554502 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 0 Cell: 75 of 1
[INFO ] E TofHitProducerNew: detId: 1259603078 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 1 Cell: 75 of 1
[INFO ] E TofHitProducerNew: detId: 1260651654 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 2 Cell: 75 of 1
[INFO ] E TofHitProducerNew: detId: 1278477446 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 3 Cell: 76 of 1
[INFO ] E TofHitProducerNew: detId: 1279526022 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 4 Cell: 76 of 1
[INFO ] E TofHitProducerNew: detId: 1281623174 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 6 Cell: 76 of 1
[INFO ] E TofHitProducerNew: detId: 1282671750 SMType: 4 SModule: 2 of 1 Module: 2 of 1 Gap: 7 Cell: 76 of 1
[INFO ] E TofHitProducerNew: detId: 134611078 SMType: 4 SModule: 0 of 1 Module: 3 of 1 Gap: 0 Cell: 8 of 1
[INFO ] E TofHitProducerNew: detId: 137756806 SMType: 4 SModule: 0 of 1 Module: 3 of 1 Gap: 3 Cell: 8 of 1
[INFO ] E TofHitProducerNew: detId: 138805382 SMType: 4 SModule: 0 of 1 Module: 3 of 1 Gap: 4 Cell: 8 of 1
[INFO ] E TofHitProducerNew: detId: 139853958 SMType: 4 SModule: 0 of 1 Module: 3 of 1 Gap: 5 Cell: 8 of 1
[INFO ] E TofHitProducerNew: detId: 141951110 SMType: 4 SModule: 0 of 1 Module: 3 of 1 Gap: 7 Cell: 8 of 1
[INFO ] E TofHitProducerNew: detId: 151391366 SMType: 4 SModule: 6 of 1 Module: 3 of 1 Gap: 0 Cell: 9 of 1
[INFO ] E TofHitProducerNew: detId: 154537094 SMType: 4 SModule: 6 of 1 Module: 3 of 1 Gap: 3 Cell: 9 of 1
[INFO ] E TofHitProducerNew: detId: 155585670 SMType: 4 SModule: 6 of 1 Module: 3 of 1 Gap: 4 Cell: 9 of 1
[INFO ] E TofHitProducerNew: detId: 156634246 SMType: 4 SModule: 6 of 1 Module: 3 of 1 Gap: 5 Cell: 9 of 1
[INFO ] E TofHitProducerNew: detId: 157682822 SMType: 4 SModule: 6 of 1 Module: 3 of 1 Gap: 6 Cell: 9 of 1

The batch output file is huge. Please find possibility to change that

Actions #1

Updated by Pierre-Alain Loizeau over 6 years ago

Hi

This is in fact an error message, probably meaning that the parameters loading or the address decoding failed: the end of the message tells that channels index up to 72 where found (as expected), while the software was somehow expecting only 1.
Therefore it is normal that the message appears for all hits.

Could you please attach to the issue the beginning of your log file, with the parameters loading output?
What could also maybe help me to track the problem is the setup you used (or the tof version).
Also, are you using the latest release or trunk? in case of trunk, which revision of trunk are you using?

Actions #2

Updated by Anna Senger over 6 years ago

Hi.
This is about ToF

[INFO ] nh - version of CbmTofHitProducerNew initializing with file
[INFO ] Found TOF geometry tof_v13-5c_0
[INFO ] Found TOF geometry tof_v13-5c_0, treat as Id 12b
[INFO ] InitParametersFromContainer
[INFO ] Parameter container contain -1 cells.
[INFO ] CbmTofHitProducerNew::InitParametersFromContainer => Number of SM types: 0 Min is 16
[INFO ] CbmTofHitProducerNew::InitParametersFromContainer => SM Type 0 Max Nb SM 0 Max Nb RPC 0 Max Nb Channels 0
[INFO ] CbmTofHitProducerNew::InitParametersFromContainer => SM Type 0 Min Nb SM 510 Min Nb RPC 128 Min Nb Channels 510
[INFO ] CbmTofHitProducerNew: found following setup:
[INFO ] SMtype 0 nsmod 1 nmod 1 ncell 0
[INFO ] CbmTofHitProducerNew: Initialization successful for 0 electronics channels

Actions #3

Updated by Anna Senger over 6 years ago

  • Status changed from New to Closed

Thank you for your comment: with proper tof digi the problem disappeared

Actions

Also available in: Atom PDF