Project

General

Profile

Actions

Bug #537

closed

Error in execution of "much_reco.C" and "much_analysis.C" in NOV15

Added by Ekata Nandy over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
12/23/2015
Due date:
% Done:

0%

Estimated time:

Description

While executing "much_reco.C" and "much_analysis.C" following error occurs----

In "much_reco.C" error is------
[INFO ] CbmMuchFindHitsStraws::Merge hits=0 merged hits=0
[INFO ] CbmMuchFindHitsStraws::Exec eventNo=0 hits=0 digis=0
I CbmLitFindGlobalTracks: Number of STS tracks: 379
I CbmLitFindGlobalTracks: Number of hits: 2548
I CbmLitTrackFinderBranch: 0 events processed
CbmLitFindGlobalTracks::Exec event: 0
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x3249380)

And in "much_analysis.C" error is-------------
[INFO ] The number of entries in the tree is 5
[INFO ] FairRootManager::ReadEvent(0): The tree has 5 entries
Event: 0
event no 1
Error in <TClonesArray::At>: index 482363776 out of bounds (size: 3541, this: 0x3af08e0)
Error in <TClonesArray::At>: index 482365408 out of bounds (size: 3541, this: 0x3af08e0)
Error in <TClonesArray::At>: index 482366976 out of bounds (size: 3541, this: 0x3af08e0)
Error in <TClonesArray::At>: index 482369776 out of bounds (size: 3541, this: 0x3af08e0)
Error in <TClonesArray::At>: index 482373904 out of bounds (size: 3541, this: 0x3af08e0)
Error in <TClonesArray::At>: index 482377888 out of bounds (size: 3541, this: 0x3af08e0)
Error in <TClonesArray::At>: index 482386528 out of bounds (size: 3541, this: 0x3af08e0)
Error in <TClonesArray::At>: index 482386864 out of bounds (size: 3541, this: 0x3af08e0)
tested
all ok
root [1]


Related issues

Is duplicate of CbmRoot - Bug #536: Problem when using CbmMatchRecoToMC with muchClosedVikas Singhal12/18/201505/13/2016

Actions
Actions #1

Updated by Volker Friese over 6 years ago

  • Status changed from New to Assigned
Actions #2

Updated by Florian Uhlig over 6 years ago

  • Status changed from Assigned to Rejected
Actions #3

Updated by Florian Uhlig over 6 years ago

  • Status changed from Rejected to Closed

Closed since the issue is a duplicate of #536.

Actions

Also available in: Atom PDF