Project

General

Profile

Actions

Bug #538

closed

FACING ERROR IN MATCHING OF STS TRACK AND MUCH TRACK

Added by Ekata Nandy over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
01/06/2016
Due date:
% Done:

0%

Estimated time:

Description

There is some problem in matching of sts track and much track in class "CbmTrackMatch" in analysis part. It's returned matching MC track ID gives some unreasonable values. To find that error we executed "much_reco.C". And it shows following error.

I CbmLitFindGlobalTracks: Number of STS tracks: 379
I CbmLitFindGlobalTracks: Number of hits: 2548
I CbmLitTrackFinderBranch: 0 events processed
CbmLitFindGlobalTracks::Exec event: 0
Error in <TClonesArray::At>: index 1 out of bounds (size: 2947, this: 0x1aae200)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x1aae200)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x1aae200)
.
.
.
Then in "much_reco.C" we commented this matching part --

//CbmMatchRecoToMC* matchTask = new CbmMatchRecoToMC();
// run->AddTask(matchTask);

By commenting this there is no error shown above,,means this error shown below is not present now.-------

Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x1aae200)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x1aae200)
Error in <TClonesArray::At>: index -1 out of bounds (size: 2947, this: 0x1aae200)

So something is going wrong in matching procedure. We saw in "CbmMatchRecoToMC" class nothing is filling up, means we checked the entries in these arrays fStsDigis, fMuchPoints,fMuchPixelDigis etc. However it shows null entry in each case. Could any one of you may look into this part.


Related issues

Is duplicate of CbmRoot - Bug #536: Problem when using CbmMatchRecoToMC with muchClosedVikas Singhal12/18/201505/13/2016

Actions
Actions #1

Updated by Ekata Nandy over 6 years ago

  • Target version set to NOV15
Actions #2

Updated by Florian Uhlig over 6 years ago

Closed since it is a duplicate of #536.

Actions #3

Updated by Florian Uhlig over 6 years ago

  • Status changed from Assigned to Closed
Actions

Also available in: Atom PDF