Project

General

Profile

Actions

Bug #61

closed

E_proj_Lab calculation in cbmgenerator/CbmUnigenGenerator.cxx (line 78)

Added by Selim Seddiki almost 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
09/01/2015
Due date:
09/10/2015
% Done:

100%

Estimated time:
5.00 h
Spent time:

Description

Dear Volker,

It is just a reminder. Boris reported very strange plab values for asymmetric systems:

UrQMD Plab Unigen Output
Au-Au at 10 AGeV: Plab = 9.99988 AGeV OK
p-p at 30 AGeV: Plab = 29.9893 AGeV OK
p-He at 30 AGeV: Plab = 61.412 AGeV WRONG
He-p at 30 AGeV: Plab = 14.621 AGeV WRONG

To me, it comes from the E_proj_Lab calculation (referred to as elab in the code) in cbmgenerator/CbmUnigenGenerator.cxx (line 78). It is calculated with a formula only valid for fixed target, symmetric systems.

You proposed to retrieve the plab/elab values directly from the UrQMD header information, as it is done in other readers.

Best regards, Selim

Actions #1

Updated by Volker Friese about 7 years ago

  • Status changed from New to Scheduled
  • Target version set to NOV15
  • Start date changed from 08/25/2014 to 06/15/2015
  • Estimated time set to 5.00 h
Actions #2

Updated by Volker Friese about 7 years ago

  • Start date changed from 06/15/2015 to 08/01/2015
Actions #3

Updated by Volker Friese about 7 years ago

  • Due date set to 08/10/2015
Actions #4

Updated by Volker Friese about 7 years ago

  • Due date changed from 08/10/2015 to 09/10/2015
  • Start date changed from 08/01/2015 to 09/01/2015
Actions #5

Updated by Volker Friese almost 7 years ago

I think that this issue was fixed with r6296, although this was done about one week before this issue was posted. Actually, the formula for calculating the energy in the lab system was wrong and is correct now.

I checked the formulae and they seem ok. I still have to test with a real UrQMD input file, though. Unfortunately, I cannot install unigen on my computer.

Retreiving p_lab and E_lab directly from the UrQMD header does not make sense, since they have the same values irrespectively of which coordinate frame is chosen for the calculation. The Unigen UrQMD converter calculates p_proj and p_targ from the sqrt(s) and beta_nn value obtained from the UrQMD event header and stores these two variables in URun. In case the calculation was done in the cm frame, p_targ = - p_proj. In case it was done in the lab frame, p_proj = p_beam and p_targ = 0. So, these two momenta define the reference system.

The CbmUnigenGenerator checks whether p_targ is different from 0. If yes, it is assumed that the momenta are given in the cm_nn frame. Then, E_lab and p_lab are calculated and from these the transformation beta into the lab system. This is not a very elegant, but working solution.

The transformation implemented in CbmUnigenGenerator is only valid for CM -> lab. In UrQMD, however, a third setting is possible (projectile frame, CTO 27 = 2). In that case, p_proj = 0 and p_targ = - p_beam. The UnigenGenerator would then apply a wrong transformation.

Actions #6

Updated by Volker Friese almost 7 years ago

  • Status changed from Scheduled to Feedback
  • Assignee changed from Volker Friese to Florian Uhlig
  • % Done changed from 0 to 80

Florian, I would like to hear your opinion.

Actions #7

Updated by Florian Uhlig almost 7 years ago

Your description given above is correct. In the old version of Unigen asymmetric systems haven't been foreseen. To be more precise the kinematic variables have always been calculated assuming a symmetric collision system. If the input was a UrQMD file which contain data of an asymmetric collision systems one got wrong results which can be seen in the original bug report.

Together with Dima we fixed the issue in Unigen and our own code.

I did a quick check and run a simulation for an asymmetric collision system (p+Au at 25 GeV) and got the following printout

[INFO ] CbmUnigenGenerator: Opening input file urqmd.pau.25gev.centr.root
[INFO ] Input data is in CM frame
[INFO ] CbmUnigenGenerator: Plab = 24.9921 AGeV
[INFO ] CbmUnigenGenerator: boost parameters: betaCM = 0.963162, gammaCM = 3.71854

For me it looks okay. If I remember correctly Iouri did some simulations after the change and confirmed that the spectra are okay.
I think if Iouri could confirm this once again we can close the issue.

Actions #8

Updated by Florian Uhlig almost 7 years ago

  • Assignee changed from Florian Uhlig to Iouri Vassiliev
Actions #9

Updated by Iouri Vassiliev over 6 years ago

  • % Done changed from 80 to 100

I've simulate 10k p+Ni @ 15GeV events /hera/cbm/prod/gen/urqmd/pni/15gev/centr/. All spectra looks reasonable.

Actions #10

Updated by Volker Friese over 6 years ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF